#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[2-9]([0-8])(?!\1)\d-?[2-9](?!1(?=1))\d\d-?\d{4}"
Local $sString = "9055551212" & @CRLF & _
"905-5551212" & @CRLF & _
"905-555-1212" & @CRLF & _
"905 555 1212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")