using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[2-9]([0-8])(?!\1)\d-?[2-9](?!1(?=1))\d\d-?\d{4}";
string input = @"9055551212
905-5551212
905-555-1212
905 555 1212";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}