const regex = new RegExp('[2-9]([0-8])(?!\\1)\\d-?[2-9](?!1(?=1))\\d\\d-?\\d{4}', 'gm')
const str = `9055551212
905-5551212
905-555-1212
905 555 1212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}