re = /[2-9]([0-8])(?!\1)\d-?[2-9](?!1(?=1))\d\d-?\d{4}/m
str = '9055551212
905-5551212
905-555-1212
905 555 1212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end