using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Intrusion signature\(s\)\:\n\n(.*)";
string input = @" * Intrusion signature(s):
- This is the text I want to extract.
* SI communication:
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}