package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Intrusion signature\(s\)\:\n\n(.*)`)
var str = ` * Intrusion signature(s):
- This is the text I want to extract.
* SI communication:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}