$re = '/Intrusion signature\(s\)\:\n\n(.*)/';
$str = ' * Intrusion signature(s):
- This is the text I want to extract.
* SI communication:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);