// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Intrusion signature\(s\)\:\n\n(.*)").unwrap();
let string = " * Intrusion signature(s):
- This is the text I want to extract.
* SI communication:
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}