const regex = /Intrusion signature\(s\)\:\n\n(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Intrusion signature\\(s\\)\\:\\n\\n(.*)', 'g')
const str = ` * Intrusion signature(s):
- This is the text I want to extract.
* SI communication:
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}