#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\((21|11)\) 9|\((?!21|11)\d{2}\) )[6789]\d{3}-\d{4}"
Local $sString = "(21) 96000-0000" & @CRLF & _
"(21) 6000-0000" & @CRLF & _
"(10) 6000-0000" & @CRLF & _
"(10) 96000-0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")