use strict;
my $str = '(21) 96000-0000
(21) 6000-0000
(10) 6000-0000
(10) 96000-0000';
my $regex = qr/(\((21|11)\) 9|\((?!21|11)\d{2}\) )[6789]\d{3}-\d{4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}