using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((21|11)\) 9|\((?!21|11)\d{2}\) )[6789]\d{3}-\d{4}";
string input = @"(21) 96000-0000
(21) 6000-0000
(10) 6000-0000
(10) 96000-0000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}