const regex = /(\((21|11)\) 9|\((?!21|11)\d{2}\) )[6789]\d{3}-\d{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\((21|11)\\) 9|\\((?!21|11)\\d{2}\\) )[6789]\\d{3}-\\d{4}', 'g')
const str = `(21) 96000-0000
(21) 6000-0000
(10) 6000-0000
(10) 96000-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}