re = /(\((21|11)\) 9|\((?!21|11)\d{2}\) )[6789]\d{3}-\d{4}/
str = '(21) 96000-0000
(21) 6000-0000
(10) 6000-0000
(10) 96000-0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end