# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\\/(.*?)$/$1\n$2/g;t' <<< "/IP/backup_jun20_2017/proddb/application_profile/mth_end_dt=2016-10-31/000000_0"