import Foundation
let pattern = #"(.*)\/(.*?)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/IP/backup_jun20_2017/proddb/application_profile/mth_end_dt=2016-10-31/000000_0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)