package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:(?:profound|other_example)(*SKIP)(*FAIL))|(?:lost|found)`)
var str = `It was lost long ago
I found it here
my feelings were profound
example other_example`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}