// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:(?:profound|other_example)(*SKIP)(*FAIL))|(?:lost|found)").unwrap();
let string = "It was lost long ago
I found it here
my feelings were profound
example other_example";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}