$re = '/(?:(?:profound|other_example)(*SKIP)(*FAIL))|(?:lost|found)/mi';
$str = 'It was lost long ago
I found it here
my feelings were profound
example other_example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);