import re
regex = re.compile(r"(?:(?:profound|other_example)(*SKIP)(*FAIL))|(?:lost|found)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("It was lost long ago\n\n"
"I found it here\n\n"
"my feelings were profound\n\n"
"example other_example")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")