re = /(?:(?:profound|other_example)(*SKIP)(*FAIL))|(?:lost|found)/mi
str = 'It was lost long ago
I found it here
my feelings were profound
example other_example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end