#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "part(0*[2-9][0-9]*|0*1[0-9]+)\.rar"
Local $sString = "S01.rar" & @CRLF & _
"S23.part1.rar" & @CRLF & _
"s4.part01.rar" & @CRLF & _
"Movie.rar" & @CRLF & _
"Youtube Movie.part1.rar" & @CRLF & _
"123Mov Ddaa.part01.rar" & @CRLF & _
"123Mov Ddaa.part001.rar" & @CRLF & _
"" & @CRLF & _
"S01.part11.rar" & @CRLF & _
"S01.part010.rar" & @CRLF & _
"S01.part100.rar" & @CRLF & _
"S01.part02.rar" & @CRLF & _
"S2.part4.rar" & @CRLF & _
"Movie.part3.rar" & @CRLF & _
"Youtube Movie.part08.rar" & @CRLF & _
"123Mov Ddaa.part002.rar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")