import re
regex = re.compile(r"part(0*[2-9][0-9]*|0*1[0-9]+)\.rar")
test_str = ("S01.rar\n"
"S23.part1.rar\n"
"s4.part01.rar\n"
"Movie.rar\n"
"Youtube Movie.part1.rar\n"
"123Mov Ddaa.part01.rar\n"
"123Mov Ddaa.part001.rar\n\n"
"S01.part11.rar\n"
"S01.part010.rar\n"
"S01.part100.rar\n"
"S01.part02.rar\n"
"S2.part4.rar\n"
"Movie.part3.rar\n"
"Youtube Movie.part08.rar\n"
"123Mov Ddaa.part002.rar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")