package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`part(0*[2-9][0-9]*|0*1[0-9]+)\.rar`)
var str = `S01.rar
S23.part1.rar
s4.part01.rar
Movie.rar
Youtube Movie.part1.rar
123Mov Ddaa.part01.rar
123Mov Ddaa.part001.rar
S01.part11.rar
S01.part010.rar
S01.part100.rar
S01.part02.rar
S2.part4.rar
Movie.part3.rar
Youtube Movie.part08.rar
123Mov Ddaa.part002.rar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}