import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "part(0*[2-9][0-9]*|0*1[0-9]+)\\.rar";
final String string = "S01.rar\n"
+ "S23.part1.rar\n"
+ "s4.part01.rar\n"
+ "Movie.rar\n"
+ "Youtube Movie.part1.rar\n"
+ "123Mov Ddaa.part01.rar\n"
+ "123Mov Ddaa.part001.rar\n\n"
+ "S01.part11.rar\n"
+ "S01.part010.rar\n"
+ "S01.part100.rar\n"
+ "S01.part02.rar\n"
+ "S2.part4.rar\n"
+ "Movie.part3.rar\n"
+ "Youtube Movie.part08.rar\n"
+ "123Mov Ddaa.part002.rar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}