using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\/]*\/\/[^\/]*\/rest\/([^\/]*).*";
string input = @"http://jira.websentinel.net/rest/api/2/search
http://jira.websentinel.net/rest/agile/1.0/board/1/sprint";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}