package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\/]*\/\/[^\/]*\/rest\/([^\/]*).*`)
var str = `http://jira.websentinel.net/rest/api/2/search
http://jira.websentinel.net/rest/agile/1.0/board/1/sprint`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}