import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\/]*\\/\\/[^\\/]*\\/rest\\/([^\\/]*).*";
final String string = "http://jira.websentinel.net/rest/api/2/search\n"
+ "http://jira.websentinel.net/rest/agile/1.0/board/1/sprint";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}