import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w";
final String string = "\n\n\n\n\n"
+ "<p>Recebo\n"
+ "dona MARIA AUGUSTA DOS SANTOS, que me\n"
+ "informa que necessita de consulta urgente com NEUROLOGISTA, tendo procurado a Secretaria da Saúde, onde foi informada que não contam com médico com agenda disponível. Por outro lado, informa que vinha sendo atendida pelo médico\n"
+ "MARIO TADEU, que se demonstrou grosseiro em face de solicitação de Relatório Médico que lhe permitiriar tentar atendimento em outro estado, ocasião em que negou-lhe o fornecimento do documento descrevendo seu problema de saúde e seu tratamento. <br></p>\n\n"
+ "<p>Colhi\n"
+ "RG e Requisição Medica do posto de saúde. Requisitaremos à secretaria de saúde o agendamento urgente,\n"
+ "assim como, requisição de cópia do\n"
+ "prontuário e relatório médico ao Dr. Mario Tadeu, no caso de impossibilidade de fornecer o relatório ao menos encaminhe-nos a cópia do prontuário. </p>\n\n"
+ "<p><br></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}