// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w").unwrap();
let string = "
<p>Recebo
dona MARIA AUGUSTA DOS SANTOS, que me
informa que necessita de consulta urgente com NEUROLOGISTA, tendo procurado a Secretaria da Saúde, onde foi informada que não contam com médico com agenda disponível. Por outro lado, informa que vinha sendo atendida pelo médico
MARIO TADEU, que se demonstrou grosseiro em face de solicitação de Relatório Médico que lhe permitiriar tentar atendimento em outro estado, ocasião em que negou-lhe o fornecimento do documento descrevendo seu problema de saúde e seu tratamento. <br></p>
<p>Colhi
RG e Requisição Medica do posto de saúde. Requisitaremos à secretaria de saúde o agendamento urgente,
assim como, requisição de cópia do
prontuário e relatório médico ao Dr. Mario Tadeu, no caso de impossibilidade de fornecer o relatório ao menos encaminhe-nos a cópia do prontuário. </p>
<p><br></p>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}