import Foundation
let pattern = #"\w"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>Recebo
dona MARIA AUGUSTA DOS SANTOS, que me
informa que necessita de consulta urgente com NEUROLOGISTA, tendo procurado a Secretaria da Saúde, onde foi informada que não contam com médico com agenda disponível. Por outro lado, informa que vinha sendo atendida pelo médico
MARIO TADEU, que se demonstrou grosseiro em face de solicitação de Relatório Médico que lhe permitiriar tentar atendimento em outro estado, ocasião em que negou-lhe o fornecimento do documento descrevendo seu problema de saúde e seu tratamento. <br></p>
<p>Colhi
RG e Requisição Medica do posto de saúde. Requisitaremos à secretaria de saúde o agendamento urgente,
assim como, requisição de cópia do
prontuário e relatório médico ao Dr. Mario Tadeu, no caso de impossibilidade de fornecer o relatório ao menos encaminhe-nos a cópia do prontuário. </p>
<p><br></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}