import re
regex = re.compile(r"\w", flags=re.MULTILINE)
test_str = ("\n\n\n\n\n"
"<p>Recebo\n"
"dona MARIA AUGUSTA DOS SANTOS, que me\n"
"informa que necessita de consulta urgente com NEUROLOGISTA, tendo procurado a Secretaria da Saúde, onde foi informada que não contam com médico com agenda disponível. Por outro lado, informa que vinha sendo atendida pelo médico\n"
"MARIO TADEU, que se demonstrou grosseiro em face de solicitação de Relatório Médico que lhe permitiriar tentar atendimento em outro estado, ocasião em que negou-lhe o fornecimento do documento descrevendo seu problema de saúde e seu tratamento. <br></p>\n\n"
"<p>Colhi\n"
"RG e Requisição Medica do posto de saúde. Requisitaremos à secretaria de saúde o agendamento urgente,\n"
"assim como, requisição de cópia do\n"
"prontuário e relatório médico ao Dr. Mario Tadeu, no caso de impossibilidade de fornecer o relatório ao menos encaminhe-nos a cópia do prontuário. </p>\n\n"
"<p><br></p>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")