using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])([A-Z])(?=[^()]*\()";
string substitution = @".$1";
string input = @"WontYouBeMyNeighbor(2018)1080p.H264.AAC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}