const regex = /(?<=[a-z])([A-Z])(?=[^()]*\()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-z])([A-Z])(?=[^()]*\\()', 'gm')
const str = `WontYouBeMyNeighbor(2018)1080p.H264.AAC`;
const subst = `.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);