$re = '/(?<=[a-z])([A-Z])(?=[^()]*\()/m';
$str = 'WontYouBeMyNeighbor(2018)1080p.H264.AAC';
$subst = ".$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;