import Foundation
let pattern = #"(?<=[a-z])([A-Z])(?=[^()]*\()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"WontYouBeMyNeighbor(2018)1080p.H264.AAC"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)