re = /(?<=[a-z])([A-Z])(?=[^()]*\()/m
str = 'WontYouBeMyNeighbor(2018)1080p.H264.AAC'
subst = '.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result