#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?"
Local $sString = "httPs://wwW.Auth.google1.com/?fdgjhfd" & @CRLF & _
"htPs://wwW.Auth.google1.com/?fdgjhfd" & @CRLF & _
"httPs:/wwW.Auth.google1.com/?fdgjhfd" & @CRLF & _
"httPs://wW.Auth.google1.co?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")