package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?`)
var str = `httPs://wwW.Auth.google1.com/?fdgjhfd
htPs://wwW.Auth.google1.com/?fdgjhfd
httPs:/wwW.Auth.google1.com/?fdgjhfd
httPs://wW.Auth.google1.co?
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}