// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?").unwrap();
let string = "httPs://wwW.Auth.google1.com/?fdgjhfd
htPs://wwW.Auth.google1.com/?fdgjhfd
httPs:/wwW.Auth.google1.com/?fdgjhfd
httPs://wW.Auth.google1.co?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}