const regex = /^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?(www\\.)?([\\w\\.]+)(\\\/[\\.\\\/\\w]*)?(\\?[\\w=&]+)?', 'gmi')
const str = `httPs://wwW.Auth.google1.com/?fdgjhfd
htPs://wwW.Auth.google1.com/?fdgjhfd
httPs:/wwW.Auth.google1.com/?fdgjhfd
httPs://wW.Auth.google1.co?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}