using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?";
string input = @"httPs://wwW.Auth.google1.com/?fdgjhfd
htPs://wwW.Auth.google1.com/?fdgjhfd
httPs:/wwW.Auth.google1.com/?fdgjhfd
httPs://wW.Auth.google1.co?
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}