# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d+)\s*-\s*(?=\d)/$1-$2/gm;t' <<< "1 - 8 - 9
90 - older
10 - 89 - 90"