use strict;
my $str = '1 - 8 - 9
90 - older
10 - 89 - 90';
my $regex = qr/\b(\d+)\s*-\s*(?=\d)/mp;
my $subst = '$1-$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";