#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d+)\s*-\s*(?=\d)"
Local $sString = "1 - 8 - 9" & @CRLF & _
"90 - older" & @CRLF & _
"10 - 89 - 90"
Local $sSubst = "$1-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)