re = /\b(\d+)\s*-\s*(?=\d)/m
str = '1 - 8 - 9
90 - older
10 - 89 - 90'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result