using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[.!]""?$).*$";
string input = @"say ""bye""
say ""bye
say ""bye.
say ""bye!
say ""bye.""
say ""bye!""
hey look this is the line not ending with period
oh this looks cool. . . . . but should not match .
say bye""
say bye"".
say bye""!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}