re = /^(?!.*[.!]"?$).*$/m
str = 'say "bye"
say "bye
say "bye.
say "bye!
say "bye."
say "bye!"
hey look this is the line not ending with period
oh this looks cool. . . . . but should not match .
say bye"
say bye".
say bye"!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end