const regex = /^(?!.*[.!]"?$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[.!]"?$).*$', 'gm')
const str = `say "bye"
say "bye
say "bye.
say "bye!
say "bye."
say "bye!"
hey look this is the line not ending with period
oh this looks cool. . . . . but should not match .
say bye"
say bye".
say bye"!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}