import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[.!]\"?$).*$";
final String string = "say \"bye\"\n"
+ "say \"bye\n"
+ "say \"bye.\n"
+ "say \"bye!\n"
+ "say \"bye.\"\n"
+ "say \"bye!\"\n"
+ "hey look this is the line not ending with period\n"
+ "oh this looks cool. . . . . but should not match .\n"
+ "say bye\"\n"
+ "say bye\".\n"
+ "say bye\"!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}